Network issues under investigation

Incident Report for TrustBuilder MFA

Resolved

The incident as been resolved.
Posted Sep 24, 2026 - 14:09 CEST

Update

We are continuing to monitor for any further issues.
Posted Sep 24, 2026 - 13:04 CEST

Update

We are continuing to monitor for any further issues.
Posted Sep 24, 2026 - 12:51 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2026 - 12:51 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2026 - 12:45 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 24, 2026 - 12:40 CEST

Investigating

We are experiencing network issues on our platform. The extent and impact of the issues are still unknown. We will update you once we have a better understanding if the problem.
Posted Sep 24, 2026 - 12:08 CEST
This incident affected: Websites (Admin Console, User Selfcare), Tokens (Browser Tokens, Mobile Tokens), and Connectors (API, SAML, Radius, OIDC).